Got Error In Ruby

1:While Installing rails 4.0.3 on ruby 1.9.3

$ gem install rails -v 4.0.3
ERROR: While executing gem ... (TypeError)
incompatible marshal file format (can't be read)
format version 4.8 required; 0.0 given

Solution:
Use ruby 2.0
===========================================================
2: Spree 2
Polyglot: found more than one candidate for compass/sass_extensions/monkey_patches: C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-0.12.2/lib/compass/sass_extensions/monkey_patches, C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-0.12.2/lib/compass/sass_extensions/monkey_patches.
Polyglot: found more than one candidate for compass/sass_extensions: C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-0.12.2/lib/compass/sass_extensions, C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-0.12.2/lib/compass/sass_extensions.
Polyglot: found more than one candidate for compass: C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-0.12.2/lib/compass, C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-0.12.2/lib/compass.
Polyglot: found more than one candidate for compass-rails: C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-rails-1.1.6/lib/compass-rails, C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/compass-rails-1.1.6/lib/compass-rails.
C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/polyglot-0.3.4/lib/polyglot.rb:65:in `require’: cannot load such file — sass/script/node (LoadError)

Solution:

gem ‘sass’, ‘3.3.0.alpha.149’
gem ‘compass’, ‘0.12.2’

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: